SuccessChanges

Summary

  1. [IndVars] Fix adding trunc instructions to unwind blocks (details)
  2. [NFC][utils] Factor remaining APIs under FunctionTestBuilder (details)
  3. [LLD] Rename lld port driver entry function to a consistent name (details)
Commit f0e3d1d6ca8c9c0d1191de1db90bd4906d16cb28 by yrouban
[IndVars] Fix adding trunc instructions to unwind blocks

Truncate instruction must not be inserted before landing pads.
The insertion point is fixed.
The file was modifiedllvm/lib/Transforms/Utils/SimplifyIndVar.cpp
Commit 93fd52329fe530d10ace5d24327e2b6d457c2ac8 by mtrofin
[NFC][utils] Factor remaining APIs under FunctionTestBuilder

Finishing the refactoring started in D93413.

Differential Revision: https://reviews.llvm.org/D93506
The file was modifiedllvm/utils/UpdateTestChecks/common.py
Commit fdd6ed8e9341f5161673e962cbd36e1f4c3968f5 by Reshabhkumar.Sharma
[LLD] Rename lld port driver entry function to a consistent name

Libraries linked to the lld elf library exposes a function named main.
When debugging code linked to such libraries and intending to set a
breakpoint at main, the debugger also sets breakpoint at the main
function at lld elf driver. The possible choice was to rename it to
link but that would again clash with lld::*::link. This patch tries
to consistently rename them to linkerMain.

Differential Revision: https://reviews.llvm.org/D91418
The file was modifiedlld/COFF/Driver.cpp
The file was modifiedlld/COFF/Driver.h
The file was modifiedlld/ELF/Driver.h
The file was modifiedlld/ELF/Driver.cpp
The file was modifiedlld/wasm/Driver.cpp