SuccessChanges

Summary

  1. [Sparc] Fix "Cannot select" error for AtomicFence on 32-bit V9 (details)
Commit 816ff985f51ea984139c0b141d402e0143bd9f2d by jrtc27
[Sparc] Fix "Cannot select" error for AtomicFence on 32-bit V9
Summary: This also adds testing of 32-bit V9 atomic lowering, splitting
the 64-bit-only tests out into their own file.
Reviewers: venkatra, jyknight
Reviewed By: jyknight
Subscribers: hiraditya, fedor.sergeev, jfb, llvm-commits, glaubitz
Tags: #llvm
Differential Revision: https://reviews.llvm.org/D69352
The file was modifiedllvm/test/CodeGen/SPARC/atomics.ll
The file was modifiedllvm/lib/Target/Sparc/SparcInstr64Bit.td
The file was addedllvm/test/CodeGen/SPARC/64atomics.ll
The file was modifiedllvm/lib/Target/Sparc/SparcInstrInfo.td