FailedConsole Output

Started by timer
Running as SYSTEM
Building remotely on labmaster2 (Zorg) in workspace /Users/buildslave/jenkins/workspace/ZorgTests
The recommended git tool is: NONE
No credentials specified
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url http://labmaster3.local/git/llvm-project.git # timeout=10
Fetching upstream changes from http://labmaster3.local/git/llvm-project.git
 > git --version # timeout=10
 > git --version # 'git version 1.9.3 (Apple Git-50)'
 > git fetch --tags --progress http://labmaster3.local/git/llvm-project.git +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git rev-parse refs/remotes/origin/main^{commit} # timeout=10
Checking out Revision 2cdb34efdac51d35da66b0017a1c1e00f65ef88d (refs/remotes/origin/main)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 2cdb34efdac51d35da66b0017a1c1e00f65ef88d # timeout=10
Commit message: "Revert "[IndirectFunctions] Skip propagating attributes to address taken functions""
 > git rev-list --no-walk 12b34ffc35f657034776ff8f20b249e26a8f91ab # timeout=10
The recommended git tool is: NONE
No credentials specified
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url http://labmaster3.local/git/llvm-zorg.git # timeout=10
Fetching upstream changes from http://labmaster3.local/git/llvm-zorg.git
 > git --version # timeout=10
 > git --version # 'git version 1.9.3 (Apple Git-50)'
 > git fetch --tags --progress http://labmaster3.local/git/llvm-zorg.git +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git rev-parse refs/remotes/origin/main^{commit} # timeout=10
Checking out Revision 722c6d15c00f846bb35b36a35b8569e57394ad44 (refs/remotes/origin/main)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 722c6d15c00f846bb35b36a35b8569e57394ad44 # timeout=10
Commit message: "Fix Windows-on-Arm buildbots"
 > git rev-list --no-walk 722c6d15c00f846bb35b36a35b8569e57394ad44 # timeout=10
No emails were triggered.
[ZorgTests] $ /bin/sh -xe /var/folders/q0/p3jrdx7n2s74x5bnw_pkhqr80000gn/T/jenkins7744053883030677074.sh
+ set -ue
+ export PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin/
+ PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin/
+ cd /Users/buildslave/jenkins/workspace/ZorgTests/llvm-zorg/test/jenkins
+ /Users/buildslave/jenkins/workspace/ZorgTests/llvm-project/llvm/utils/lit/lit.py --xunit-xml-output=/Users/buildslave/jenkins/workspace/ZorgTests/testresults.xunit.xml -v .
Traceback (most recent call last):
  File "/Users/buildslave/jenkins/workspace/ZorgTests/llvm-project/llvm/utils/lit/lit.py", line 6, in <module>
    main()
  File "/Users/buildslave/jenkins/workspace/ZorgTests/llvm-project/llvm/utils/lit/lit/main.py", line 24, in main
    opts = lit.cl_arguments.parse_args()
  File "/Users/buildslave/jenkins/workspace/ZorgTests/llvm-project/llvm/utils/lit/lit/cl_arguments.py", line 26, in parse_args
    default=lit.util.usable_core_count())
  File "/Users/buildslave/jenkins/workspace/ZorgTests/llvm-project/llvm/utils/lit/lit/util.py", line 121, in usable_core_count
    n = os.cpu_count() or 1
AttributeError: 'module' object has no attribute 'cpu_count'
Build step 'Execute shell' marked build as failure
Recording test results
ERROR: Step ‘Publish JUnit test result report’ failed: Test reports were found but none of them are new. Did leafNodes run? 
For example, /Users/buildslave/jenkins/workspace/ZorgTests/testresults.xunit.xml is 1 hr 59 min old

Hide Details

No emails were triggered. Finished: FAILURE