Regression

Test Clang 9.0.0 / lldb-api.commands/process/attach-resume.TestAttachResume.py (from lldb-api)

Failing for the past 1 build (Since Unstable#2504 )
Took 1 min 2 sec.

Stacktrace

Script:
--
/usr/local/Frameworks/Python.framework/Versions/3.7/bin/python3.7 /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/dotest.py -u CXXFLAGS -u CFLAGS --codesign-identity lldb_codesign --arch x86_64 --build-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex -t --env TERM=vt100 --skip-category gmodules --skip-category watchpoint --arch=x86_64 --env LLVM_LIBS_DIR=/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./lib --arch x86_64 --build-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex --lldb-module-cache-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-lldb/lldb-api --clang-module-cache-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-clang/lldb-api --executable /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin/lldb --compiler /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin/clang --dsymutil /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin/dsymutil --llvm-tools-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin --lldb-libs-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./lib /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/commands/process/attach-resume -p TestAttachResume.py
--
Exit Code: 1

Command Output (stdout):
--
lldb version 13.0.99 (http://labmaster3.local/git/llvm-project.git revision c88c46080a75467788b4379f49fc664061c2c6d0)
  clang revision c88c46080a75467788b4379f49fc664061c2c6d0
  llvm revision c88c46080a75467788b4379f49fc664061c2c6d0
libstdcxx tests will not be run because: Don't know how to build with libstdcxx on macosx
Skipping following debug info categories: ['dwo']

--
Command Output (stderr):
--
Change dir to: /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/commands/process/attach-resume
runCmd: settings clear -all
output: 

runCmd: settings set symbols.enable-external-lookup false
output: 

runCmd: settings set target.inherit-tcc true
output: 

runCmd: settings set target.detach-on-error false
output: 

runCmd: settings set target.auto-apply-fixits false
output: 

runCmd: settings set plugin.process.gdb-remote.packet-timeout 60
output: 

runCmd: settings set symbols.clang-modules-cache-path "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-lldb/lldb-api"
output: 

runCmd: settings set use-color false
output: 

runCmd: setting set target.prefer-dynamic-value no-dynamic-values
output: 

runCmd: process attach -p 37052
runCmd failed!
error: attach failed: developer mode is not enabled on this machine and this is a non-interactive debug session.


FAIL: LLDB (/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/bin/clang-x86_64) :: test_attach_continue_interrupt_detach (TestAttachResume.AttachResumeTestCase)
<bound method SBProcess.Kill of <lldb.SBProcess; proxy of <Swig Object of type 'lldb::SBProcess *' at 0x10ff169f0> >>: success

Restore dir to: /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/tools/lldb/test
======================================================================
FAIL: test_attach_continue_interrupt_detach (TestAttachResume.AttachResumeTestCase)
   Test attach/continue/interrupt/detach
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/packages/Python/lldbsuite/test/decorators.py", line 119, in wrapper
    func(*args, **kwargs)
  File "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/commands/process/attach-resume/TestAttachResume.py", line 27, in test_attach_continue_interrupt_detach
    self.process_attach_continue_interrupt_detach()
  File "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/commands/process/attach-resume/TestAttachResume.py", line 36, in process_attach_continue_interrupt_detach
    self.runCmd("process attach -p " + str(popen.pid))
  File "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/packages/Python/lldbsuite/test/lldbtest.py", line 2177, in runCmd
    msg if (msg) else CMD_MSG(cmd))
AssertionError: False is not True : Command 'process attach -p 37052
Error output:
error: attach failed: developer mode is not enabled on this machine and this is a non-interactive debug session.
' did not return successfully
Config=x86_64-/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/bin/clang
----------------------------------------------------------------------
Ran 1 test in 61.638s

RESULT: FAILED (0 passes, 1 failures, 0 errors, 0 skipped, 0 expected failures, 0 unexpected successes)

--