Regression

Test Clang 7.0.1 / lldb-api.macosx/version_zero.TestGetVersionZeroVersion.py (from lldb-api)

Failing for the past 1 build (Since #3644 )
Took 0.54 sec.

Stacktrace

Script:
--
/usr/local/Frameworks/Python.framework/Versions/3.7/bin/python3.7 /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/dotest.py -u CXXFLAGS -u CFLAGS --codesign-identity lldb_codesign --arch x86_64 --build-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex -t --env TERM=vt100 --skip-category gmodules --skip-category watchpoint --arch=x86_64 --env LLVM_LIBS_DIR=/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./lib --arch x86_64 --build-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex --lldb-module-cache-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-lldb/lldb-api --clang-module-cache-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-clang/lldb-api --executable /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin/lldb --compiler /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/clang_701_build/bin/clang --dsymutil /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin/dsymutil --llvm-tools-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin --lldb-libs-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./lib /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/macosx/version_zero -p TestGetVersionZeroVersion.py
--
Exit Code: 1

Command Output (stdout):
--
lldb version 13.0.99 (http://labmaster3.local/git/llvm-project.git revision 6d753b0751b1f4b6fb6851b69627244722c57a64)
  clang revision 6d753b0751b1f4b6fb6851b69627244722c57a64
  llvm revision 6d753b0751b1f4b6fb6851b69627244722c57a64
Skipping the following test categories: ['gmodules', 'watchpoint', 'libstdcxx', 'dwo', 'llgs', 'fork']

--
Command Output (stderr):
--
Change dir to: /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/macosx/version_zero
runCmd: settings clear -all
output: 

runCmd: settings set symbols.enable-external-lookup false
output: 

runCmd: settings set target.inherit-tcc true
output: 

runCmd: settings set target.detach-on-error false
output: 

runCmd: settings set target.auto-apply-fixits false
output: 

runCmd: settings set plugin.process.gdb-remote.packet-timeout 60
output: 

runCmd: settings set symbols.clang-modules-cache-path "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-lldb/lldb-api"
output: 

runCmd: settings set use-color false
output: 

runCmd: setting set target.prefer-dynamic-value no-dynamic-values
output: 

FAIL: LLDB (/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/clang_701_build/bin/clang-x86_64) :: test_get_version_zero (TestGetVersionZeroVersion.TestGetVersionForZero)
Restore dir to: /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/tools/lldb/test
======================================================================
ERROR: test_get_version_zero (TestGetVersionZeroVersion.TestGetVersionForZero)
   Read in a library with a version of 0.0.0.  Test SBModule::GetVersion
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/macosx/version_zero/TestGetVersionZeroVersion.py", line 25, in test_get_version_zero
    self.yaml2obj("libDylib.dylib.yaml", self.getBuildArtifact("libDylib.dylib"))
  File "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/packages/Python/lldbsuite/test/lldbtest.py", line 1702, in yaml2obj
    system([command])
  File "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/packages/Python/lldbsuite/test/lldbtest.py", line 521, in system
    raise cpe
subprocess.CalledProcessError: Command '/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin/yaml2obj -o=/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/macosx/version_zero/TestGetVersionZeroVersion.test_get_version_zero/libDylib.dylib libDylib.dylib.yaml' returned non-zero exit status 1.
Config=x86_64-/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/clang_701_build/bin/clang
----------------------------------------------------------------------
Ran 1 test in 0.035s

RESULT: FAILED (0 passes, 0 failures, 1 errors, 0 skipped, 0 expected failures, 0 unexpected successes)

--