AbortedConsole Output

+ set -u
+ rm -rf build.properties
+ cd llvm-project
+ git tag -a -m 'First Commit' first_commit 97724f18c79c7cc81ced24239eb5e883bf1398ef
fatal: tag 'first_commit' already exists
+ true
++ git describe --match first_commit
+ git_desc=first_commit-339522-g7ce2de2ce4e
++ echo first_commit-339522-g7ce2de2ce4e
++ cut -f 2 -d -
+ export GIT_DISTANCE=339522
+ GIT_DISTANCE=339522
++ echo first_commit-339522-g7ce2de2ce4e
++ cut -f 3 -d -
+ sha=g7ce2de2ce4e
+ export GIT_SHA=7ce2de2ce4e
+ GIT_SHA=7ce2de2ce4e
+ cd -
/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized
+ export PATH=/usr/local/bin:/usr/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/bin:/usr/local/bin
+ PATH=/usr/local/bin:/usr/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/bin:/usr/local/bin
+ python llvm-zorg/zorg/jenkins/monorepo_build.py lldb-cmake-sanitized build --assertions '--projects=clang;libcxx;libcxxabi;lld;lldb' --cmake-type=Release
Error: missing dependency: os_version v10.13.5, found v10.14 installed, requested from clang_build_dependencies.dep:0: os_version == 10.13.5 # Oldest CI nodes are currently 10.13.3
Dependency met brew cmake v3.11.2
Dependency met brew ninja v1.8.2
Dependency met pip psutil v5.4.5
Dependency met pip six v1.11.0
Error: missing dependency: xcode v9.4.1, found v10.1 installed, requested from clang_build_dependencies.dep:5: xcode == 9.4.1
@@@ Clean @@@
Removing module cache: /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/lldb-build/module.cache
Completed at: 2020-01-15T15:02:50
@@@@@@
@@@ Cmake @@@
cd /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/lldb-build
'/usr/local/bin/cmake' '-G' 'Ninja' '/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/llvm-project/llvm' '-DCMAKE_BUILD_TYPE=Release' '-DCMAKE_EXPORT_COMPILE_COMMANDS=ON' '-DCMAKE_INSTALL_PREFIX=/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/lldb-install' '-DCMAKE_MAKE_PROGRAM=/usr/local/bin/ninja' '-DLLDB_TEST_USER_ARGS=--arch;x86_64;--build-dir;/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/lldb-build/lldb-test-build.noindex;-s=/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/test/logs;-t;--env;TERM=vt100' '-DLLDB_ENABLE_PYTHON=On' '-DLLVM_ENABLE_ASSERTIONS:BOOL=TRUE' '-DLLVM_ENABLE_MODULES=On' '-DLLVM_ENABLE_PROJECTS=clang;libcxx;libcxxabi;lld;lldb' '-DLLVM_LIT_ARGS=-v --time-tests --shuffle --xunit-xml-output=/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/test/results.xml -v --timeout 1200' '-DLLVM_VERSION_PATCH=99' '-DLLVM_TARGETS_TO_BUILD=X86' '-DLLVM_USE_SANITIZER=Address;Undefined' '-DLLDB_TEST_C_COMPILER=/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/host-compiler/bin/clang' '-DLLDB_TEST_CXX_COMPILER=/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/host-compiler/bin/clang++' '-DCMAKE_C_COMPILER=/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/host-compiler/bin/clang' '-DCMAKE_CXX_COMPILER=/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/host-compiler/bin/clang++'
-- clang project is enabled
-- clang-tools-extra project is disabled
-- compiler-rt project is disabled
-- debuginfo-tests project is disabled
-- libc project is disabled
-- libclc project is disabled
-- libcxx project is enabled
-- libcxxabi project is enabled
-- libunwind project is disabled
-- lld project is enabled
-- lldb project is enabled
-- llgo project is disabled
-- mlir project is disabled
-- openmp project is disabled
-- parallel-libs project is disabled
-- polly project is disabled
-- pstl project is disabled
-- Could NOT find Z3: Found unsuitable version "0.0.0", but required is at least "4.7.1" (found Z3_LIBRARIES-NOTFOUND)
-- Found libtool - /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool
-- Found LibXml2: /usr/lib/libxml2.dylib (found version "2.9.4") 
-- Native target architecture is X86
-- Threads enabled.
-- Doxygen disabled.
-- Go bindings disabled.
-- Ninja version: 1.8.2
-- Found ld64 - /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld
-- Could NOT find OCaml (missing: OCAMLFIND OCAML_VERSION OCAML_STDLIB_PATH) 
-- Could NOT find OCaml (missing: OCAMLFIND OCAML_VERSION OCAML_STDLIB_PATH) 
-- OCaml bindings disabled.
-- LLVM host triple: x86_64-apple-darwin18.0.0
-- LLVM default target triple: x86_64-apple-darwin18.0.0
-- Building with -fPIC
-- Constructing LLVMBuild project information
-- Linker detection: ld64
-- Targeting X86
-- Found compiler-rt directory: /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/host-compiler/lib/clang/11.0.0/lib/darwin
-- Manually linking compiler-rt library: /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/host-compiler/lib/clang/11.0.0/lib/darwin/libclang_rt.asan_osx_dynamic.dylib
-- Could not find ParallelSTL, libc++abi will not attempt to use it but the build may fail if the libc++ in use needs it to be available.
-- Linker detection: ld64
CMake Warning at /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/llvm-project/libcxx/CMakeLists.txt:705 (message):
  Unsupported value of LLVM_USE_SANITIZER: Address;Undefined
Call Stack (most recent call first):
  /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/llvm-project/libcxx/CMakeLists.txt:719 (get_sanitizer_flags)


-- Found compiler-rt directory: /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/host-compiler/lib/clang/11.0.0/lib/darwin
-- Manually linking compiler-rt library: /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/host-compiler/lib/clang/11.0.0/lib/darwin/libclang_rt.asan_osx_dynamic.dylib
-- Linker detection: ld64
-- Linker detection: ld64
-- Clang version: 11.0.99
-- LLD version: 11.0.99
-- Enable editline support in LLDB: TRUE
-- Enable curses support in LLDB: TRUE
-- Enable LZMA compression support in LLDB: TRUE
-- Could NOT find LuaAndSwig (missing: LUA_LIBRARIES LUA_INCLUDE_DIR) 
-- Enable Lua scripting support in LLDB: FALSE
-- Enable Python scripting support in LLDB: TRUE
-- Found LibXml2: /usr/lib/libxml2.dylib (found suitable version "2.9.4", minimum required is "2.8") 
-- Enable Libxml 2 support in LLDB: TRUE
-- LLDB version: 11.0.99git
-- Symbols (liblldb): exporting all symbols from the lldb namespace
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE) 
-- Could NOT find epydoc
-- LLDB Tests use just-built debugserver: /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/lldb-build/./bin/debugserver
-- LLVM FileCheck Found: /usr/local/bin/FileCheck
-- Version: 0.0.0
-- Performing Test HAVE_THREAD_SAFETY_ATTRIBUTES -- failed to compile
-- Performing Test HAVE_GNU_POSIX_REGEX -- failed to compile
-- Performing Test HAVE_POSIX_REGEX -- success
-- Performing Test HAVE_STEADY_CLOCK -- success
-- Configuring done
-- Generating done
-- Build files have been written to: /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/lldb-build
Completed at: 2020-01-15T15:03:05
@@@@@@
@@@ Build @@@
cd /Users/buildslave/jenkins/workspace/lldb-cmake-sanitized/lldb-build
'/usr/local/bin/ninja' '-v'
Sending interrupt signal to process
ninja: build stopped: interrupted by user.
script returned exit code 143
sh: line 1:  2348 Terminated: 15          JENKINS_SERVER_COOKIE=$jsc '/bin/sh' -xe '/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized@tmp/durable-a72a104e/script.sh' > '/Users/buildslave/jenkins/workspace/lldb-cmake-sanitized@tmp/durable-a72a104e/jenkins-log.txt' 2>&1