Regression

Test Clang 9.0.0 / lldb-shell.Settings.TestFrameFormatColor.test (from lldb-shell)

Failing for the past 1 build (Since #5041 )
Took 30 sec.

Stacktrace

Script:
--
: 'RUN: at line 1';   /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/bin/clang --target=specify-a-target-or-use-a-_host-substitution --target=x86_64-apple-darwin19.5.0 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk -fmodules-cache-path=/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-clang/lldb-shell -g -O0 /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/Shell/Settings/Inputs/main.c -o /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/tools/lldb/test/Shell/Settings/Output/TestFrameFormatColor.test.tmp.out
: 'RUN: at line 2';   /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/bin/lldb --no-lldbinit -S /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/tools/lldb/test/Shell/lit-lldb-init -x -b -s /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/Shell/Settings/TestFrameFormatColor.test /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/tools/lldb/test/Shell/Settings/Output/TestFrameFormatColor.test.tmp.out | /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/bin/FileCheck /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/Shell/Settings/TestFrameFormatColor.test
--
Exit Code: 1

Command Output (stderr):
--
clang-16: warning: argument unused during compilation: '-fmodules-cache-path=/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-clang/lldb-shell' [-Wunused-command-line-argument]
[0;1;31merror: [0mprocess exited with status -1 (tried to attach to process already being debugged)
/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/Shell/Settings/TestFrameFormatColor.test:12:10: error: CHECK: expected string not found in input
# CHECK: 
         ^
<stdin>:1:1: note: scanning from here
(lldb) command source -s 0 '/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/tools/lldb/test/Shell/lit-lldb-init'
^

Input file: <stdin>
Check file: /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/Shell/Settings/TestFrameFormatColor.test

-dump-input=help explains the following input dump.

Input was:
<<<<<<
          1: (lldb) command source -s 0 '/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/tools/lldb/test/Shell/lit-lldb-init' 
check:12     X~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ error: no match found
          2: Executing commands in '/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/tools/lldb/test/Shell/lit-lldb-init'. 
check:12     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          3: (lldb) # LLDB init file for the LIT tests. 
check:12     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          4: (lldb) settings set symbols.enable-external-lookup false 
check:12     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          5: (lldb) settings set plugin.process.gdb-remote.packet-timeout 60 
check:12     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          6: (lldb) settings set interpreter.echo-comment-commands false 
check:12     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          .
          .
          .
>>>>>>

--