Regression

Test DWARF4 / lldb-api.api/multiple-debuggers.TestMultipleDebuggers.py (from lldb-api)

Failing for the past 1 build (Since #3676 )
Took 4.9 sec.

Stacktrace

Script:
--
/usr/local/Frameworks/Python.framework/Versions/3.7/bin/python3.7 /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/dotest.py -u CXXFLAGS -u CFLAGS --codesign-identity lldb_codesign --arch x86_64 --build-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex -t --env TERM=vt100 --skip-category gmodules --skip-category watchpoint --arch=x86_64 --dwarf-version=4 --env LLVM_LIBS_DIR=/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./lib --arch x86_64 --build-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex --lldb-module-cache-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-lldb/lldb-api --clang-module-cache-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-clang/lldb-api --executable /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin/lldb --compiler /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/clang_900_build/bin/clang --dsymutil /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin/dsymutil --llvm-tools-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./bin --lldb-libs-dir /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/./lib /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/api/multiple-debuggers -p TestMultipleDebuggers.py
--
Exit Code: 1

Command Output (stdout):
--
lldb version 14.0.99 (http://labmaster3.local/git/llvm-project.git revision 697ea09d47a93d92e40990a38fccf9e246cc22e6)
  clang revision 697ea09d47a93d92e40990a38fccf9e246cc22e6
  llvm revision 697ea09d47a93d92e40990a38fccf9e246cc22e6
Skipping the following test categories: ['gmodules', 'watchpoint', 'libstdcxx', 'dwo', 'llgs', 'fork']
Building LLDB Driver (/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/api/multiple-debuggers/TestMultipleDebuggers.test_multiple_debuggers/multi-process-driver) from sources multi-process-driver.cpp
Building LLDB Driver (/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/api/multiple-debuggers/TestMultipleDebuggers.test_multiple_debuggers/testprog) from sources testprog.cpp
Running test /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/api/multiple-debuggers/TestMultipleDebuggers.test_multiple_debuggers/multi-process-driver

--
Command Output (stderr):
--
/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/api/multiple-debuggers/TestMultipleDebuggers.test_multiple_debuggers/multi-process-driver: replacing existing signature
Change dir to: /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/api/multiple-debuggers
runCmd: settings clear -all
output: 

runCmd: settings set symbols.enable-external-lookup false
output: 

runCmd: settings set target.inherit-tcc true
output: 

runCmd: settings set target.detach-on-error false
output: 

runCmd: settings set target.auto-apply-fixits false
output: 

runCmd: settings set plugin.process.gdb-remote.packet-timeout 60
output: 

runCmd: settings set symbols.clang-modules-cache-path "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/module-cache-lldb/lldb-api"
output: 

runCmd: settings set use-color false
output: 

runCmd: setting set target.prefer-dynamic-value no-dynamic-values
output: 

Adding tearDown hook:         self.addTearDownHook(lambda: os.remove(self.driver_exe))


Adding tearDown hook:         self.addTearDownHook(lambda: os.remove(self.inferior_exe))


FAIL: LLDB (/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/clang_900_build/bin/clang-x86_64) :: test_multiple_debuggers (TestMultipleDebuggers.TestMultipleSimultaneousDebuggers)
Executing tearDown hook:         self.addTearDownHook(lambda: os.remove(self.inferior_exe))


Executing tearDown hook:         self.addTearDownHook(lambda: os.remove(self.driver_exe))


Restore dir to: /Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/tools/lldb/test
======================================================================
ERROR: test_multiple_debuggers (TestMultipleDebuggers.TestMultipleSimultaneousDebuggers)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/packages/Python/lldbsuite/test/decorators.py", line 149, in wrapper
    return func(*args, **kwargs)
  File "/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/llvm-project/lldb/test/API/api/multiple-debuggers/TestMultipleDebuggers.py", line 40, in test_multiple_debuggers
    check_call([self.driver_exe, self.inferior_exe], env=env)
  File "/usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/lib/python3.7/subprocess.py", line 328, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/api/multiple-debuggers/TestMultipleDebuggers.test_multiple_debuggers/multi-process-driver', '/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/lldb-build/lldb-test-build.noindex/api/multiple-debuggers/TestMultipleDebuggers.test_multiple_debuggers/testprog']' died with <Signals.SIGILL: 4>.
Config=x86_64-/Users/buildslave/jenkins/workspace/lldb-cmake-matrix/clang_900_build/bin/clang
----------------------------------------------------------------------
Ran 1 test in 4.443s

RESULT: FAILED (0 passes, 0 failures, 1 errors, 0 skipped, 0 expected failures, 0 unexpected successes)

--